Tehtävien ajoitus

Tehtävien ajoituksen avulla voit ajoittaa komentoja, ohjelmia tai komentosarjoja suoritettavaksi tiettynä ajankohtana:

  • Tutustu ennen Tehtävien ajoituksen käyttämistä kohtaan Tarkistuslista.
  • Jos haluat lisätietoja tietyistä tehtävistä, tutustu kohtaan Toimintaohjeet.
  • Yleisiä taustatietoja on kohdassa Käsitteet.
  • Ongelmien ratkaisemiseen liittyviä ohjeita on kohdassa Vianmääritys.


Tehtävien ajoitukseen liittyvä tarkistuslista

Tarkistuslista

Oheisessa taulukossa on luettelo tehtävistä, joita yleisimmin suoritetaan Tehtävien ajoituksen avulla. Täydellinen luettelo Tehtävien ajoitukseen liittyvistä ohjeista on kohdassa Toimintaohjeet.

Vaihe: | Ohje:
Sinun on lisättävä tehtävä, ennen kuin voit ajoittaa sen suorittamisen. | Uuden tehtävän ajoittaminen
Kun olet luonut ajoitettuja tehtäviä, voit muokata tehtävään liittyvää ohjelmaa tai tehtävän ajoitusta tai muita tehtävään liittyviä asetuksia. | Ajoitetun tehtävän muokkaaminen
Voit poistaa tarpeettomiksi käyneet ajoitetut tehtävät. | Ajoitetun tehtävän poistaminen
Jos ajoitettu tehtävä käynnistyy, kun olet työskentelemässä tietokoneella, voit lopettaa tehtävän suorittamisen ja käynnistää tehtävän myöhemmin uudelleen. | Ajoitetun tehtävän suorittamisen lopettaminen
Voit lopettaa kaikki ajoitetut tehtävät väliaikaisesti tai keskeyttää niiden suorittamisen ja jatkaa suorittamista myöhemmin. | Kaikkien ajoitettujen tehtävien lopettaminen väliaikaisesti


Toimintaohjeet...

  • Tehtävien ajoitus
  • Tehtävien ajoituksen ylläpito


Tehtävien ajoittaminen
  • Tehtävien ajoituksen käynnistäminen
  • Uuden tehtävän ajoittaminen
  • Ajoitetun tehtävän muokkaaminen
  • Ajoitetun tehtävän poistaminen
  • Ajoitetun tehtävän lopettaminen
  • Tehtävän suorittaminen välittömästi


Tehtävien ajoituksen käynnistäminen

  • Voit käynnistää Tehtävien ajoituksen kaksoisnapsauttamalla ensin Oma tietokone -kuvaketta ja sitten Ajoitetut tehtävät -kansiota.
  • Kaksoisnapsauta ensin Ajoitetut tehtävät ja sitten Lisää ajoitettu tehtävä -vaihtoehtoa. Näyttöön tulee ohjattu ohjelmien ajoitustoiminto, joka opastaa sinua tehtävän ajoittamisessa.


Uuden tehtävän ajoittaminen
  1. Käynnistä Tehtävien ajoitus.
  2. Kaksoisnapsauta Lisää ajoitettu tehtävä -vaihtoehtoa.
  3. Noudata ohjatun ohjelmien ajoitustoiminnon antamia ohjeita.

Huomautuksia

  • Jos haluat määrittää tehtävälle lisäasetuksia, valitse Anna tämän tehtävän lisäominaisuudet valittaessa Valmis -vaihtoehto ohjatun toiminnon viimeisestä ikkunasta.
  • Jos haluat toistaa uuden tehtävän, valitse ensin Anna tämän tehtävän lisäominaisuudet valittaessa Valmis -vaihtoehto ohjatun toiminnon viimeisestä ikkunasta, sitten Ajoitus-välilehti ja lopuksi Lisäasetukset.
  • Jos tehtäväohjelma edellyttää parametrien määrittämistä, valitse ensin Anna tämän tehtävän lisäominaisuudet valittaessa Valmis -vaihtoehto ohjatun toiminnon viimeisestä ikkunasta ja sitten Tehtävä-välilehti. Kirjoita haluamasi parametrit Suorita-ruutuun tehtävän polun jälkeen.
  • Varmista, että järjestelmäpäivämäärä ja -kellonaika on määritetty tietokoneeseesi oikein. Tehtävien ajoitus käyttää näitä tietoja määrittäessään ajastettujen tehtävien suorittamisajankohdan. Voit muuttaa aikaa tai päivämäärää kaksoinapsauttamalla tehtäväpalkissa näkyvää kellonaikaa.


Ajoitetun tehtävän muokkaaminen

Ajastetun tehtävän muokkaaminen
  1. Käynnistä Tehtävien ajoitus.
  2. Napsauta hiiren kakkospainikkeella tehtävää, jota haluat muokata, ja valitse sitten Ominaisuudet.
  3. Tee yksi tai useita seuraavista toiminnoista:
    • Muuta suoritettava ohjelma kirjoittamalla Suorita-ikkunaan uuden ohjelman polku.
    • Muuta tehtävän ajoitusta valitsemalla Ajoitus-välilehti.
    • Mukauta tehtävän asetuksia valitsemalla Asetukset-välilehti.

Huomautuksia

  • Jos muutat käyttäjätunnusta tai vaihdat suoritettavaa ohjelmaa, sinun on annettava käyttäjätunnuksen salasana.
  • Jos tehtäväohjelmaan liittyy komentorivin asetuksia, kirjoita ne Suorita-ruutuun tehtävän polun jälkeen.
  • Jos tehtäväohjelman polussa on välilyöntejä, kirjoita koko polku lainausmerkkeihin ("").
  • Varmista, että järjestelmäpäivämäärä ja -kellonaika on määritetty tietokoneeseesi oikein. Tehtävien ajoitus käyttää näitä tietoja määrittäessään ajastettujen tehtävien suorittamisajankohdan. Voit muuttaa aikaa tai päivämäärää kaksoinapsauttamalla tehtäväpalkissa näkyvää kellonaikaa.


Ajoitetun tehtävän poistaminen
  1. Käynnistä Tehtävien ajoitus.
  2. Napsauta hiiren kakkospainikkeella tehtävää, jonka haluat poistaa, ja valitse Poista.

Huomautuksia

  • Kun poistat ajoitetun tehtävän, se poistuu vain tehtäväluettelosta. Ohjelmatiedostoa ei poisteta kiintolevyltä.
  • Voit poistaa ajoitetun tehtävän myös painamalla DELETE-näppäintä.


Parhaillaan suoritettavan ajoitetun tehtävän lopettaminen
  1. Käynnistä Tehtävien ajoitus.
  2. Napsauta hiiren kakkospainikkeella tehtävää, jonka suorittamisen haluat lopettaa. Valitse sitten Lopeta tehtävä.

Huomautuksia

  • Jos ajoitettu tehtävä käynnistää toisen ohjelman, Lopeta tehtävä -komento lopettaa ainoastaan alkuperäisen ajoitetun tehtävän suorittamisen, ei toista tehtävää.
  • Jos haluat käynnistää tehtävän uudelleen, napsauta tehtävää hiiren kakkospainikkeella ja valitse Suorita.


Tehtävän suorittaminen heti
  1. Käynnistä Tehtävien ajoitus.
  2. Napsauta hiiren kakkospainikkeella tehtävää, jonka haluat käynnistää, ja valitse Suorita.

Huomautuksia

  • Voit lopettaa tehtävän suorittamisen valitsemalla Tiedosto Lopeta tehtävä.
  • Jos haluamasi tehtävän suorittaminen ei onnistu, valitse Lisäasetukset Näytä loki. Näyttöön tulee tehtäväloki.


Tehtävien ajoituksen ylläpito
  • Suoritettujen ajoitettujen tehtävien lokin tarkasteleminen
  • Ajoitettujen tehtävien tarkasteleminen etätietokoneessa
  • Kaikkien ajoitettujen tehtävien lopettaminen väliaikaisesti
  • Tehtävien ajoituksen keskeyttäminen
  • AT-palvelutilin määrittäminen


Suoritettujen ajoitettujen tehtävien lokin tarkasteleminen
  1. Käynnistä Tehtävien ajoitus.
  2. Valitse Lisäasetukset Näytä loki.


Ajoitettujen tehtävien tarkasteleminen etätietokoneessa
  1. Kaksoisnapsauta työpöydän Verkkoympäristö-kuvaketta.
  2. Kaksoisnapsauta sen tietokoneen kuvaketta, jossa haluat tarkastella ajoitettuja tehtäviä.
  3. Valitse Ajoitetut tehtävät.

Huomautuksia

  • Voit tarkastella Windows-etätietokoneen tehtäviä vain, jos sinulla on järjestelmänvalvojan oikeudet kyseiseen tietokoneeseen.
  • Voit muokata Windows-etätietokoneen tehtäviä vain,jos etätietokoneeseen on asennettu etärekisteröintiohjelma ja koneen x$-asema on jaettu. x on kiintolevy, joka sisältää Ajoitetut tehtävät -kansion. Tietokoneessa on oltava Windows, ja sinun käyttäjätunnuksellesi on oltava määritettynä oikeudet etärekisteriin. Voit määrittää käyttäjät, joilla on oikeudet Windows-tietokoneen etärekisteriin, Ohjauspaneelin Salasanat-sovelluksen avulla.


Kaikkien ajoitettujen tehtävien lopettaminen väliaikaisesti
  1. Käynnistä Tehtävien ajoitus.

  2. Valitse Lisäasetukset-valikosta Keskeytä Tehtävien ajoitus.

Huomautuksia

  • Tätä komentoa kannattaa käyttää, jos olet suorittamassa toista ohjelmaa, esimerkiksi peliä, tai asentamassa ohjelmistoa, etkä halua suorittaa ajoitettuja tehtäviä samanaikaisesti.
  • Keskeytyksen aikana suoritettaviksi määritetyt tehtävät suoritetaan jälleen seuraavana ajoitettuna ajankohtana.
  • Voit palauttaa kaikkien tehtävien ajoituksen valitsemalla Lisäasetukset Jatka Tehtävien ajoituksen käyttämistä.


Tehtävien ajoituksen keskeyttäminen
  1. Käynnistä Tehtävien ajoitus.
  2. Valitse Lisäasetukset-valikosta Lopeta Tehtävien ajoituksen käyttö.

Huomautus

  • Kun keskeytät Tehtävien ajoituksen, ajoitettuja tehtäviä ei suoriteta. Tehtävien ajoitus ei käynnisty automaattisesti, kun seuraavan kerran käynnistät Windowsin.


AT-palvelutilin määrittäminen
  1. Käynnistä Tehtävien ajoitus.
  2. Valitse Lisäasetukset AT-palvelutili.
  3. Valitse Tili ja kirjoita käyttäjätunnus, jolla haluat suorittaa Ajoitettuna-komennon avulla ajoitettuja tehtäviä.
  4. Kirjoita Salasana- ja Vahvista salasana -ruutuun käyttäjätunnukseen liittyvä salasana.

Huomautuksia

  • AT-palvelu on käytettävissä vain Windows NT -käyttöjärjestelmässä.
  • Voit myös valita Järjestelmätili-komennon. Tällöin Tehtävien ajoitus suorittaa Ajoitettuna-komennolla ajoitetut tehtävät käyttämällä LocalSystem-tiliä. Sen käyttäminen edellyttää järjestelmänvalvojan oikeuksia.

  • Tarkista, että määrittämälläsi käyttäjätunnuksella on riittävät oikeudet Ajoitettuna-komennolla ajoitettujen tehtävien suorittamiseen. Jos esimerkiksi ajoitat tehtäviä, joita vain järjestelmänvalvojat ovat oikeutettuja suorittamaan, määritä järjestelmänvalvojatunnus.


Tehtävien ajoitukseen liittyviä käsitteitä

Käsitteet

Tässä jaksossa on yleisiä taustatietoja Tehtävien ajoituksesta:

  • Johdanto Tehtävien ajoitukseen
  • Tehtävien ajoituksen käyttäminen
  • Tehtävien ajoitus ja Ajoitettuna-komento
  • Tehtävien ajoitus ja suojaus
  • Vianmääritys


Johdanto Tehtävien ajoitukseen

Käyttämällä Tehtävien ajoitusta voit ajastaa erilaisia tehtäviä, kuten Levyn eheytyksen, suoritettavaksi silloin, kun sinulle parhaiten sopii. Taustalla suoritettava Tehtävien ajoitus käynnistyy aina, kun käynnistät Windowsin.

Tehtävien ajoituksen avulla voit tehdä esimerkiksi seuraavia tehtäviä:

  • ajoittaa tehtävän suoritettavaksi päivittäin, viikoittain, kuukausittain tai tiettynä ajankohtana (kuten järjestelmän käynnistyksen yhteydessä)
  • muuttaa tehtävän ajoitusta
  • lopettaa ajoitetun tehtävän
  • mukauttaa tehtävän suorittamista määritettynä ajankohtana.


Tehtävien ajoituksen käyttäminen

Tehtävien ajoitus asennetaan automaattisesti Windows-käyttöjärjestelmän mukana. Voit käyttää ajoituspalvelua kaksoisnapsauttamalla Oma tietokone -ikkunassa Ajoitetut tehtävät -kansiota.

Voit lisätä tehtäviä kaksoisnapsauttamalla Lisää ajoitettu tehtävä -komentoa. Se käynnistää ohjatun ohjelmien ajoitustoiminnon. Voit lisätä tehtäviä myös vetämällä komentosarjoja, ohjelmia tai tiedostoja Windowsin Resurssienhallinnasta tai työpöydältä Ajoitetut tehtävät -ikkunaan.

Tehtävien ajoituksen avulla voit myös muokata, poistaa tai keskeyttää ajoitettuja tehtäviä, tarkastella suoritettujen tehtävien lokia tai tarkastella tehtäviä, jotka on ajoitettu suoritettaviksi etätietokoneessa.

Lisätietoja Tehtävien ajoituksen käynnistämisestä on kohdassa Toimintaohjeet.

Tehtävien ajoitukseen liittyvä suositus:

Windows-käyttöjärjestelmässä Tehtävien ajoituksen avulla voi määrittää suoritettavaksi minkä tahansa sovelluksen. Jotta Tehtävien ajoituksesta olisi mahdollisimman paljon hyötyä, varmista, että tietokoneen kello ja päivämäärä on määritetty oikein, ennen kuin lisäät ajoitetun tehtävän.


Tehtävien ajoitus ja Ajoitettuna-komento

Tehtävien ajoituksen lisäksi voit suorittaa tehtäviä automaattisesti myös Ajoitettuna-komennon avulla.

Tehtävien ajoitus ja Ajoitettuna-komento ovat kaksi eri asiaa, mutta ne toimivat yhdessä. Kun ajoitat tehtävän käyttämällä Ajoitettuna-komentoa, tehtävä tulee näkyviin Tehtävien ajoitus -ikkunan tehtäväluettelossa.

Tehtävien ajoituksen avulla voit muokata sellaisen tehtävän ominaisuuksia, joka on ajoitettu käyttämällä Ajoitettuna-komentoa. Jos teet näin, saat tehtävän käyttöösi vain Tehtävien ajoituksen kautta, et enää Ajoitettuna -komennon avulla.

Kun haluat määrittää, millä käyttäjätunnuksella voidaan suorittaa Ajoitettuna-komennolla ajoitettuja tehtäviä, valitse ensin Oma tietokone -ikkunasta Ajoitetut tehtävät ja sitten Lisäasetukset-valikosta AT-palvelutili.

Huomautus

  • AT-palvelu on käytettävissä vain Windows NT -käyttöjärjestelmässä.


Tehtävien ajoituksen suojaus

Voit parantaa Tehtävien ajoituksen suojausta liittämällä tiettyyn tehtävään käyttäjätunnuksen ja salasanan. Tämän jälkeen toinen käyttäjä ei voi peruuttaa tai poistaa tehtävää.

Huomautuksia

  • Tämä suojausominaisuus on käytettävissä vain Windows NT:ssä.
  • Sinun on annettava käyttäjätunnus ohjatussa ohjelmien ajoitustoiminnossa, ennen kuin voit jatkaa tehtävän ajoittamista. Salasanat eivät ole pakollisia.
  • Voit muuttaa salasanaa tai määrittää uuden salasanan valitsemalla Avaa tämän tehtävän lisäominaisuudet valittaessa Valmis -vaihtoehdon ohjatun toiminnon viimeisestä ikkunasta.


Tehtävien ajoituksen vianmääritys

Jos ajoitettua tehtävää ei suoriteta määrittämänäsi ajankohtana, napsauta tehtävää hiiren kakkospainikkeella ja valitse Ominaisuudet. Tarkista Tehtävä-välilehdestä, että Käytössä-vaihtoehto on valittuna. Tarkista Ajoitus-välilehdestä, että ajoitus on määritetty oikein.

Jos tehtävään liittyvä ohjelma ei toimi oikein, sinun on ehkä määritettävä komentoriviasetuksia. Saat lisätietoja tiettyyn ohjelmaan liittyvistä komentoriviasetuksista seuraavasti:

  • Tutustu ohjelman käytönaikaiseen Ohjeeseen, mikäli se on saatavissa.

  • Kirjoita komentoriville ( ohjelma on ohjelman nimi)

    • ohjelma /?


Windows NT -komponenttia ei ole asennettu

Ohjelmaa ei voitu käynnistää.

Mahdollisia syitä:

    • Järjestelmänvalvoja on poistanut komponentin.
    • Järjestelmänvalvoja on muuttanut tiedostoon liittyvää käytäntöä.
    • Ohjelmaa ei ole asennettu tietokoneeseen.
    • Ohjelma on poistettu vahingossa.
    • Tiedosto on vahingoittunut.

Jos tietokoneesi ylläpidosta huolehtii järjestelmänvalvoja, pyydä häntä selvittämään, miksi ohjelma ei käynnisty.